- Written by Robert Ling
- Posted on March 18, 2026
- Updated on March 18, 2026
- 837 Views
The Analytics Node (AN) enables the correlation of 5-tuple data from Flows and DMF metadata with the corresponding packets retrieved from the Recorder Node (RN). Previously, the system displayed Egress sFlow® to indicate potentially recorded flow packets.
- Written by Jasleen Phangara
- Posted on September 19, 2025
- Updated on September 19, 2025
- 2391 Views
The Recorder Node (RN) supports being managed by CloudVision (CV) on-prem starting DMF 8.7.0. This feature extends support to CVaaS starting DMF 8.8.0. Recorder Node was not supported with CVaaS before 8.8.0 because of an RN requirement to store the query results file in CV while archiving the query results. However, this was not permitted on CVaaS as these files might contain data that cannot be stored in a cloud service. This feature supports CVaaS by allowing the RN to store query result files.
- Written by Jasleen Phangara
- Posted on September 19, 2025
- Updated on September 22, 2025
- 2231 Views
This document provides a comprehensive overview of the redesigned Alerts page, detailing its features and how to use them to monitor and manage Fabric health effectively. The new design improves clarity, usability, and the efficiency of alert management.
- Written by Arpit Bansal
- Posted on May 1, 2015
- Updated on May 1, 2015
- 9561 Views
This feature allows to advertise routes learnt via BGP into IS IS network or IS IS routes into BGP network. It also
- Written by Sunil Jat
- Posted on March 18, 2026
- Updated on March 18, 2026
- 816 Views
The regex-session action enables matching of Regular Expression patterns against packet content. When a packet matches the specified pattern, its session is tracked based on configured timeouts and other parameters including, anchor, offset, and ip-proto.
- Written by Prachi Modi
- Posted on December 16, 2024
- Updated on December 16, 2024
- 4502 Views
With the 18.0 release, you can prevent clients using locally-administered MAC addresses from accessing your network. Network administrators can ensure that only clients using their device’s globally unique MAC addresses are able to connect to the network. By making sure that only devices with globally unique MAC addresses connect to the network, you can mitigate potential security threats associated with spoofing or unauthorized access by having control over device identification.
- Written by Vu Nguyen
- Posted on September 25, 2024
- Updated on September 25, 2024
- 5303 Views
In the BGP Update message’s AS_PATH, routers have the capability to perform route aggregation and combine the ASes an update has traversed, merging the discrete entries into an AS_SET. Routers can also do this within the local confederation with member AS numbers, using an AS_CONFED_SET. Route aggregation can be problematic as it blurs the semantics of what it means to originate a route. RFC 6472 recommends not using AS_SET or AS_CONFED_SET in BGP, and further justifies reasoning as to why, as well as provides a recommended way to handle updates with these messages.
- Written by Chunxi Yu
- Posted on January 21, 2019
- Updated on July 13, 2026
- 5970 Views
Similar to reconfiguring the traffic-class to transmit-queue map, the traffic-class to priority-group mapping can also be changed using the CLI. This enables configuration capability to the user who can adjust the mapping based on the nature of the traffic. This configuration change doesn’t inhibit the flow of traffic.
- Written by Andrew Li
- Posted on April 18, 2018
- Updated on July 8, 2026
- 10336 Views
This feature removes an ARP entry when the physical port, on which the ARP entry's MAC address is learned, goes down. This feature applies only to dynamic ARP entries, not static ARP entries. In addition, if the physical port, which is down,
- Written by Sunil Kumar
- Posted on April 24, 2025
- Updated on April 30, 2025
- 3558 Views
This document describes the workflow for renaming a Group Name in DMF. Navigate to Security → Groups and select Groups.
- Written by Ruoyi Wang
- Posted on March 4, 2025
- Updated on March 4, 2025
- 3907 Views
When this feature is disabled, the dst_vlan field in the switch extension always equals to the src_vlan field for L2 traffic. When this feature is enabled, the dst_vlan field will be the 802.1Q VLAN ID of the outgoing frame for L2 traffic.
- Written by Prachi Modi
- Posted on February 20, 2023
- Updated on February 21, 2023
- 9098 Views
In the 14.0 release, CloudVision Cognitive Unified Edge (CV-CUE) introduces a new Report, WiFi-Radios Instantaneous.
- Written by Aditi Vaidya
- Posted on August 23, 2019
- Updated on August 26, 2019
- 11694 Views
Arista WM gathers a wealth of data about the wireless deployment. The data gathered includes Wireless Intrusion
- Written by Md Ghouse
- Posted on August 18, 2025
- Updated on September 30, 2025
- 2207 Views
Even if the LEM table is exhausted and the routes are being added to LPM due to LEM overflow, the reserved amount of entries in LEM should persist.
- Written by Srinivas Kovvuri
- Posted on December 22, 2017
- Updated on June 5, 2025
- 16143 Views
Equal Cost Multi-path (ECMP) provides the ability to load-share traffic across multiple next-hops. When a next-hop fails or is deleted all flows are affected. This is due to the nature of the load-balancing algorithm which re-calculates a new hash for the flows based on the remaining active next-hops.
- Written by Emil Maric
- Posted on February 16, 2021
- Updated on June 19, 2026
- 13435 Views
Routes covered by a resilient equal-cost multi-path (RECMP) prefix are types of routes that make use of hardware tables dedicated for equal-cost multi-path (ECMP) routing. Resilient ECMP deduping is a new feature wherein the switch will reactively attempt to reduce the number of ECMP hardware table entries allocated by forcing routes that share the same set of next hops but point to different hardware table entries to point to the same hardware table entry when hardware resource utilization is high. Forcing RECMP routes to change the hardware table entry that they point to may potentially cause a traffic flow disruption for any existing flows going over that route. The deduping process will attempt to minimize the amount of potential traffic loss caused.
- Written by David Graham
- Posted on September 17, 2024
- Updated on September 18, 2024
- 5812 Views
When this feature is enabled, responses to gNMI get requests as well as NETCONF get-config responses will contain the default values for YANG leafs if those leafs do not have any other value. This means that where a leaf value would normally be returned in a response, its default value (as defined in the YANG model) will be returned if the leaf does not have any other value assigned to it. Before this change, leafs that had a default value would not have been included in gNMI get responses.
- Written by David Graham
- Posted on July 15, 2025
- Updated on July 15, 2025
- 3064 Views
When this feature is enabled, responses to gNMI subscribe requests contain the default values for YANG leafs if those leafs do not have any other value.
- Written by Aditi Vaidya
- Posted on August 23, 2019
- Updated on August 26, 2019
- 11708 Views
The transmit power configured on UI is now treated as EIRP (Equivalent Isotropically Radiated Power) instead of
- Written by Lavanya Conjeevaram
- Posted on June 29, 2016
- Updated on February 7, 2022
- 12694 Views
The BGP labeled unicast (LU) RFC is used to advertise BGP routes with a stack of MPLS labels, thereby allowing
- Written by Cong Du
- Posted on June 29, 2016
- Updated on August 28, 2019
- 13279 Views
This feature provides support for advertising IPv4 unicast Network Layer Reachability Information (NLRI) with
- Written by Navneet Sinha
- Posted on June 29, 2016
- Updated on November 17, 2016
- 12198 Views
EOS 4.17.0F adds support for IPv4 address family in OSPFv3 (multiple address family support) based on RFC5838.
- Written by Mathew Simon
- Posted on November 22, 2017
- Updated on December 27, 2021
- 12113 Views
Multi Agent, Platform independent. This feature supports RFC 7606, which provides improved security and
- Written by Yaonan Liang
- Posted on August 12, 2025
- Updated on August 27, 2025
- 2812 Views
This feature provides support for advertising VPN-IPv4 Network Layer Reachability Information (NLRI) with IPv6 next-hops over IPv6 peering sessions described as the Extended Next Hop Encoding capability in RFC8950. Extended Next Hop Encoding capability can be supported for IPv4 unicast, IPv4 Labeled Unicast, and IPv4 VPN address and sub-address families (1/1, 1/4, 1/128 respectively) per RFC. The Extended Next Hop support for IPv4 unicast is described in RFC 5549 .
- Written by Shyam Kota
- Posted on January 22, 2019
- Updated on March 17, 2026
- 11363 Views
RIB Route Control is a collection of mechanisms for controlling how IP routing table entries get used. Next hop resolution policy adds support for preventing recursive resolution of next hops based on route map evaluation of resolving routes.
- Written by Prachi Modi
- Posted on January 17, 2024
- Updated on January 17, 2024
- 7551 Views
With the 16.0 release, CloudVision Cognitive Unified Edge (CV-CUE) introduces the Client Roaming Explorer. It provides a graphical and tabular view of a client’s roaming events from one access point (AP) to another AP.
- Written by Jeff Hornsberger
- Posted on April 1, 2026
- Updated on July 17, 2026
- 1121 Views
RDMA over converged ethernet version 2 (RoCEv2) is a UDP protocol for transferring memory blocks between compute nodes. It is used for AI applications. RoCEv2 aware sampled flow tracking with IPFIX export is an enhancement that allows customers access to RoCEv2 flow information, for the purposes of analyzing and monitoring traffic associated with AI workloads.
- Written by Noah Tinker
- Posted on March 13, 2026
- Updated on March 13, 2026
- 937 Views
Link Aggregation Group (LAG) or port channel interfaces comprise multiple member interfaces. Network devices typically distribute packets across the member interfaces using a hash computed from packet header fields. The Round-Robin LAG Distribution feature introduces a new packet distribution method: the round-robin method. A round-robin LAG configuration balances packets evenly across all member interfaces in a sequential, round-robin fashion.
- Written by Deeksha Srivastava
- Posted on March 12, 2020
- Updated on August 27, 2026
- 12040 Views
This feature adds support for ‘match interface’ clause under route map config for Bgp policy application in
- Written by Ashish Sahota
- Posted on March 2, 2026
- Updated on March 2, 2026
- 838 Views
EOS 4.35.2F introduces support to configure tag at interface level configuration to add a route tag attribute for connected routes. These tags are optionally configured per address.This feature adds the ability to define tags for local/directly connected prefixes as part of ‘ip address’ command. These tags can then be used in a RCF function or route-map for policy decision and route filtering as opposed to maintaining prefix-list when redistributing routes between protocols.
- Written by Harry Dhillon
- Posted on March 18, 2026
- Updated on March 18, 2026
- 866 Views
Beginning with DMF version 8.9, the action keyword is required to add or modify actions within a managed service. This keyword is a mandatory token across all managed service submodes, providing a consistent way to define service behaviors.
- Written by Mihyar Baroudi
- Posted on December 8, 2015
- Updated on February 5, 2022
- 11336 Views
The broadcast queue towards the CPU is shared among all interfaces of the forwarding chip. So broadcast storm on a
- Written by Anoop Dawani
- Posted on September 30, 2015
- Updated on February 7, 2022
- 10267 Views
This feature allows routing traffic across two Vrf domains on the same switch using an external loopback cable
- Written by David Cronin
- Posted on March 3, 2022
- Updated on September 7, 2026
- 35736 Views
Routing control functions (RCF) is a language that can be used to express route filtering and attribute modification logic in a powerful and programmatic fashion. This document serves as a reference guide for: Routing protocol attributes , Operators for comparing and modifying attributes
- Written by David Cronin
- Posted on March 3, 2022
- Updated on September 9, 2026
- 21996 Views
Routing control functions (RCF) is a language that can be used to express route filtering and attribute modification logic in a powerful and programmatic fashion. This document serves as a reference guide for Bgp agent points of application:
- Written by Paraic Gallagher
- Posted on March 17, 2025
- Updated on September 7, 2026
- 4337 Views
Routing control functions (RCF) is a language that can be used to express route filtering and attribute modification logic in a powerful and programmatic fashion. This document serves as a reference guide for IpRib agent points of application Configuration of RCF
- Written by Shamit Kapadia
- Posted on May 3, 2022
- Updated on May 12, 2026
- 14004 Views
Routing control functions (RCF) is a language that can be used to express route filtering and attribute modification logic in a powerful and programmatic fashion. This document serves as a reference guide for Isis agent points of application Configuration of RCF.
- Written by Roger Levesque
- Posted on January 3, 2023
- Updated on January 28, 2026
- 12154 Views
Routing control functions (RCF) is a language that can be used to express route filtering and attribute modification logic in a powerful and programmatic fashion.This document serves as a reference guide for KernelFib agent points of application:
- Written by David Cronin
- Posted on March 4, 2022
- Updated on January 22, 2026
- 28995 Views
Routing control functions (RCF) is a language that can be used to express route filtering and attribute modification logic in a powerful and programmatic fashion.
- Written by Shamit Kapadia
- Posted on May 3, 2022
- Updated on January 28, 2026
- 12615 Views
Routing control functions (RCF) is a language that can be used to express route filtering and attribute modification logic in a powerful and programmatic fashion.
- Written by Paraic Gallagher
- Posted on March 17, 2025
- Updated on January 28, 2026
- 4339 Views
Routing control functions (RCF) is a language that can be used to express route filtering and attribute modification logic in a powerful and programmatic fashion.
- Written by Hemanth Murthy
- Posted on April 24, 2015
- Updated on May 13, 2015
- 10386 Views
In an MLAG setup, routing on a switch (MLAG peer) is possible using its own bridge/system MAC, VARP MAC or VRRP MAC.
- Written by Kalash Nainwal
- Posted on December 14, 2020
- Updated on September 29, 2026
- 19608 Views
RSVP-TE, the Resource Reservation Protocol (RSVP) for Traffic Engineering (TE), is used to distribute MPLS labels for steering traffic and reserving bandwidth. The Label Edge Router (LER) feature implements the headend functionality, i.e., RSVP-TE tunnels can originate at an LER which can steer traffic into the tunnel.
- Written by Martin Stigge
- Posted on October 22, 2018
- Updated on October 7, 2026
- 16928 Views
RSVP-TE applies the Resource Reservation Protocol (RSVP) for Traffic Engineering (TE), i.e., to distribute MPLS labels for steering traffic and reserving bandwidth.
- Written by Martin Stigge
- Posted on March 3, 2025
- Updated on December 17, 2025
- 4883 Views
RSVP-TE P2MP LER adds ingress and egress support for Point-to-Multipoint (P2MP) LSPs to be used in Multicast Virtual Private Network (MVPN) as an extension to the LSR support which adds transit support.
- Written by Jeff Hornsberger
- Posted on September 10, 2024
- Updated on September 10, 2024
- 5998 Views
RSVP-TE P2MP LSR adds transit support for Point-to-Multipoint (P2MP) LSPs. Specifically the feature adds protocol support for the transit role as described in RFC 4875.
- Written by Sunil Kumar
- Posted on March 18, 2026
- Updated on March 18, 2026
- 790 Views
The Rule Groups Dashboard aligns with modern DMF User Interface (UI) standards. This view maintains full functional parity with the previous version while delivering a consistent and unified user experience.
- Written by Dhruba Jyoti Pokhrel
- Posted on December 11, 2022
- Updated on December 12, 2022
- 9331 Views
With the 13.0 release, you can integrate SAML SSO with a captive portal for authentication. The SAML integration functionality is only available for captive portals hosted on the Arista Cloud. It is not available if the captive portal is hosted on third-party servers or on the access point.
- Written by Jeevan Kamisetty
- Posted on November 4, 2020
- Updated on May 14, 2026
- 25131 Views
Network administrators require access to flow information that passes through various network elements, for the purpose of analyzing and monitoring their networks. This feature provides access to IP flow information by sampling traffic flows in ingress and/or egress directions on the interfaces on which it is configured. The samples are then used to create flow records, which are exported to the configured collectors in the IPFIX format. Egress Flow tracking is supported from EOS-4.29.0F on the DCS-7170B-64C series and supported on 7280, 7500 and 7800 series platforms from EOS-4.31.1"
- Written by Sergiu Stambolian
- Posted on March 31, 2017
- Updated on May 25, 2026
- 12610 Views
Sampled Mirroring is an extension of the Mirroring feature and sampling is a property of the individual mirroring session: when the session's sample rate N is specified, a packet eligible for mirroring will have a 1/N chance of being mirrored, that is, 1 packet is mirrored for every N packets.
