EVPN and VCS Commands

bfd vtep evpn

The bfd vtep evpn command to configure the BGP PIC Edge for EVPN VXLAN routes for remote VTEPs. This command is configured under the VXLAN Tunnel Interface (VTI).

The no bfd vtep evpn command removes bfd vtep evpn configuration from the running-config.

Command Mode

VXLAN Tunnel Interface (VTI) Mode

Command Syntax

bfd vtep evpn interval interval-milliseconds min-rx min-rx-milliseconds multiplier multiplier-range

no bfd vtep evpn interval interval-milliseconds min-rx min-rx-milliseconds multiplier multiplier-range

Parameters
  • interval Set transmit rate in milliseconds.
    • interval-milliseconds Rate in milliseconds. Value ranges from 50 to 60000 milliseconds.
  • min-rx Set expected minimum incoming rate in milliseconds.
    • min-rx-milliseconds Rate in milliseconds. Value ranges from 50 to 60000 milliseconds.
  • multiplier Sets the BFD multiplier.
    • multiplier-range The value ranges from 3 to 50.

Example

In this example (assuming symmetric configuration on other PE devices) any BFD for VXLAN session initiated on the VTI would have a detect time of 300ms (interval of 100ms multiplied by 3).
switch(config-if-Vx1)# bfd vtep evpn interval 100 min-rx 100 multiplier 3

encapsulation vxlan layer-3 set next-hop igp-cost

The encapsulation vxlan layer-3 set next-hop igp-cost command configure the underlay IGP metric for the VTEP reachability to be considered for BGP best path selection in the IP VRF that is importing the EVPN route.

The no encapsulation vxlan layer-3 set next-hop igp-cost or default encapsulation vxlan layer-3 set next-hop igp-cost command removes all the IGP cost for VTEP running configurations on the switch.

Command Mode

BGP Address-Family Configuration

Command Syntax

encapsulation vxlan layer-3 set next-hop igp-cost

no encapsulation vxlan layer-3 set next-hop igp-cost

default encapsulation vxlan layer-3 set next-hop igp-cost

Examples
  • The following command configures the IGP cost for VTEP feature on the switch :
    switch(config-router-bgp)# address-family evpn
    switch(config-router-bgp-af)# [no | default] encapsulation vxlan layer-3 set next-hop igp-cost

leak routes

The leak routes command configures an inter-VRF route-leaking policy to allow routes to be leaked from one VRF to another using a route map.

The no leak routes and default leak routes commands removing the specified route-leaking policy from running-config.

Command Mode

Router General Configuration

Command Syntax

leak routes source-vrf source_name subscribe-policy route_map

no leak routes source-vrf source_name

default leak routes source-vrf source_name

Example

  • These commands configure routes to be leaked from VRF VRF1 to VRF VRF2 according to the policy described in route-map RM1.
    switch(config)# router general
    switch(config-router-general)# vrf VRF2
    switch(config-router-general-vrf-VRF2)# leak routes source-vrf VRF1 subscribe-policy RM1
    switch(config-router-general-vrf-VRF2)# exit
    switch(config-router-general)# exit
    switch(config)#

next-hop resolution disabled

The next-hop resolution disabled command disables the next-hop resolution in routes received from BGP-EVPN peers.

The no next-hop resolution disabled and the default next-hop resolution disabled commands enable the next-hop resolution in routes received from BGP-EVPN peers.

Command Mode

Router-BGP Address-Family Configuration

Command Syntax

next-hop resolution disabled

Example

This command disables the next-hop resolution in routes received from BGP-EVPN peers.

switch(config)# router bgp 65002
switch(config-router-bgp)# address-family evpn
switch(config-router-bgp-af)# next-hop resolution disabled
switch(config-router-bgp-af)#

redistribute bgp evpn vxlan

The redistribute bgp evpn vxlan command enables BGP-EVPN routes to be redistributed to VCS which in turn advertises them to all VTEPs within the DC.

The no redistribute bgp evpn vxlan and the default redistribute bgp evpn vxlan commands disable the redistribution of BGP-EVPN routes to VCS.

Command Mode

CVX-VXLAN Configuration

Command Syntax

redistribute bgp evpn vxlan

Example

This command enables redistribution of BGP-EVPN routes to VCS.

switch(config)# cvx
switch(config-cvx)# no shutdown
switch(config-cvx)# service vxlan
switch(config-cvx-vxlan)# no shutdown
switch(config-cvx-vxlan)# redistribute bgp evpn vxlan

redistribute router-mac next-hop vtep primary

Use the redistribute router-mac next-hop vtep primary command in the MAC VRF configuration mode to advertise an EVPN type-2 route for the VARP MAC with a nexthop of the primary VTEP IP.

Configuration Mode

MAC VRF

Command Syntax

redistribute router-mac next-hop vtep primary

Parameters
  • router-mac Router Ethernet address.
  • next-hop Cnfigure the advertised next-hop.
  • vtep Associate next-hop with a VTEP.
  • primary Use the primary VTEP IP.

Example

The following example uses the command redistribute router-mac next-hop vtep primary in the MAC VRF configuration.

switch(config)# router bgp 65003
switch(config-router-bgp-65003)# neighbor 223.255.255.1 remote-as 65001
switch(config-router-bgp-65003)# neighbor 223.255.255.2 remote-as 65002
switch(config-router-bgp-65003)# neighbor 223.255.255.4 remote-as 65003

switch(config)# vlan 100
switch(config-vlan-100)# rd 1:100
switch(config-vlan-100-rd-100)# route-target both 1:100
switch(config-vlan-100-rd-100)# redistribute learned
switch(config-vlan-100-rd-100)# redistribute router-mac next-hop vtep primary  
  
switch(config)# vlan 200
switch(config-vlan-200)# rd 1:200
switch(config-vlan-100-rd-200)# route-target both 1:200
switch(config-vlan-100-rd-200)# redistribute learned
switch(config-vlan-100-rd-200)# redistribute router-mac next-hop vtep primary

redistribute service vxlan

The redistribute service vxlan command enables BGP to redistribute the Layer 2 bridging information received from VCS.

The no redistribute service vxlan and the default redistribute service vxlan commands disable the redistribution of the bridging information received from VCS.

Command Mode

Router-BGP VNI Configuration

Command Syntax

redistribute service vxlan

Example

This command enables redistribution of the Layer 2 bridging information received from VCS.

switch(config)# router bgp 100
switch(config-router-bgp)# vni-aware-bundle bundle1
switch(config-macvrf-bundle1)# redistribute service vxlan

route-target

The route-target command configures a well-known extended community that is used by BGP-EVPN to export routes from or import routes into MAC-VRF.

The no route-target and default route-target commands delete the route-target configuration.

Command Mode

Router-BGP VNI Configuration

Syntax

route-target {export | import | both} rt

no route-target

default route-target

Parameters
  • export     configures a well-known extended community that is attached to the routes exported by BGP-EVPN.
  • import     configures a well known extended community that identifies the received routes that need to be imported into the MAC-VRF specified by the VNI bundle.
  • both     configures the same extended community for import and export of routes.
  • rt     route-target extended community.

This command configures a well-known extended community for import and export of routes.

switch(config)# router bgp 100
switch(config-router-bgp)# vni-aware-bundle bundle1
switch(config-macvrf-bundle1)# route-target both 503:12
switch(config-macvrf-bundle1)#

route-target export

The route-target export command allows the user to export routes from a VRF to the local VPN table using the route target extended community list.

The no route-target export and default route-target export commands remove the routes from the VPN table.

Command Mode

Router-BGP VNI Configuration

Syntax

route-target export [evpn | vpn-ipv4 | vpn-ipv6] RT

no route-target export

default route-target export

Parameters
  • evpn     EVPN address family.
  • vpn-ipv4     MPLS L3 VPN IPv4 unicast address family.
  • vpn-ipv6     MPLS L3 VPN IPv6 unicast address family.
  • RT     route-target extended community.
Examples
  • These commands export routes from vrf-red to the VPN table.
    switch(config)# service routing protocols model multi-agent
    switch(config)# mpls ip
    switch(config)# router bgp 65001
    switch(config-router-bgp)# vrf vrf-red
    switch(config-router-bgp-vrf-vrf-red)# rd 1:1
    switch(config-router-bgp-vrf-vrf-red)# route-target export vpn-ipv4 10:10
    switch(config-router-bgp-vrf-vrf-red)# route-target export vpn-ipv6 10:20
  • These commands export routes from vrf-red to the EVPN table.
    switch(config)# router bgp 65001
    switch(config-router-bgp)# vrf vrf-red
    switch(config-router-bgp-vrf-vrf-red)# rd 1:1
    switch(config-router-bgp-vrf-vrf-red)# route-target export evpn 10:1

route-target import

The route-target import command allows the user to import route target extended community lists from the local VPN table to the target VRF.

The no route-target import and default route-target import commands remove the routes from the VPN table.

Command Mode

Router-BGP VNI Configuration

Syntax

route-target import [evpn | vpn-ipv4 | vpn-ipv6] RT

no route-target import

default route-target import

Parameters
  • evpn     EVPN address family.
  • vpn-ipv4     MPLS L3 VPN IPv4 unicast address family.
  • vpn-ipv6     MPLS L3 VPN IPv6 unicast address family.
  • RT    route-target extended community.
Examples
  • These commands import routes from the VPN table to vrf-blue.
    switch(config)# service routing protocols model multi-agent
    switch(config)# mpls ip
    switch(config)# router bgp 65001
    switch(config-router-bgp)# vrf vrf-blue
    switch(config-router-bgp-vrf-vrf-blue)# rd 2:2
    switch(config-router-bgp-vrf-vrf-blue)# route-target import vpn-ipv4 10:10
    switch(config-router-bgp-vrf-vrf-blue)# route-target import vpn-ipv6 10:20
  • These commands import routes from the EVPN table to vrf-blue.
    switch(config)# router bgp 65001
    switch(config-router-bgp)# vrf vrf-blue
    switch(config-router-bgp-vrf-vrf-blue)# rd 2:2
    switch(config-router-bgp-vrf-vrf-blue)# route-target import evpn 10:1

route-target route-map

The route-target route-map command allows the user to export and import route target extended community lists from one VRF to another using route maps.

The no route-target route-map and default route-target route-map commands remove the routes from the VPN table.

Command Mode

Router-BGP VNI Configuration

Syntax

route-target {import | export} [evpn | vpn-ipv4 | vpn-ipv6] route-map RM

no route-target route-map

default route-target route-map

Parameters
  • evpn     EVPN address family.
  • vpn-ipv4     MPLS L3 VPN IPv4 unicast address family.
  • vpn-ipv6     MPLS L3 VPN IPv6 unicast address family.
  • RM     route-map extended community.
Examples
  • These commands export routes from vrf-red to the VPN table.
    switch(config)# service routing protocols model multi-agent
    switch(config)# mpls ip
    switch(config)# router bgp 65001
    switch(config-router-bgp)# vrf vrf-red
    switch(config-router-bgp-vrf-vrf-red)# rd 1:1
    switch(config-router-bgp-vrf-vrf-red)# route-target export vpn-ipv4 10:10
    switch(config-router-bgp-vrf-vrf-red)# route-target export vpn-ipv6 10:20
    switch(config-router-bgp-vrf-vrf-red)# route-target export vpn-ipv4 route-map EXPORT_V4_ROUTES_T0_VPN_TABLE
    switch(config-router-bgp-vrf-vrf-red)# route-target export vpn-ipv6 route-map EXPORT_V6_ROUTES_T0_VPN_TABLE
  • These commands export routes from vrf-red to the EVPN table.
    switch(config)# router bgp 65001
    switch(config-router-bgp)# vrf vrf-red
    switch(config-router-bgp-vrf-vrf-red)# rd 1:1
    switch(config-router-bgp-vrf-vrf-red)# route-target export evpn 10:1
    switch(config-router-bgp-vrf-vrf-red)# route-target export evpn route-map EXPORT_ROUTES_T0_EVPN_TABLE
  • These commands import routes from the VPN table to vrf-blue.
    switch(config)# service routing protocols model multi-agent
    switch(config)# mpls ip
    switch(config)# router bgp 65001
    switch(config-router-bgp)# vrf vrf-blue
    switch(config-router-bgp-vrf-vrf-blue)# rd 1:1
    switch(config-router-bgp-vrf-vrf-blue)# route-target import vpn-ipv4 10:10
    switch(config-router-bgp-vrf-vrf-blue)# route-target import vpn-ipv6 10:20
    switch(config-router-bgp-vrf-vrf-blue)# route-target import vpn-ipv4 route-map IMPORT_V4_ROUTES_VPN_TABLE
    switch(config-router-bgp-vrf-vrf-blue)# route-target import vpn-ipv6 route-map IMPORT_V6_ROUTES_VPN_TABLE
  • These commands import routes from the EVPN table to vrf-blue.
    switch(config)# router bgp 65001
    switch(config-router-bgp)# vrf vrf-blue
    switch(config-router-bgp-vrf-vrf-blue)# rd 2:2
    switch(config-router-bgp-vrf-vrf-blue)# route-target import evpn 10:1
    switch(config-router-bgp-vrf-vrf-blue)# route-target import evpn route-map IMPORT_ROUTES_FROM_EVPN_TABLE

router general

The router general command places the switch in Router-General Configuration Mode for the configuration of protocol-independent routing.

The no router general and default router general commands remove all protocol-independent routing configuration from running-config.

Command Mode

Global Configuration

Command Syntax

router general

no router general

default router general

Example

  • These commands place the switch in Router-General Configuration Mode and display the commands available there.
    switch(config)# router general
    switch(config-router-general)# ?
      command            Configuration command
      control-functions  Routing control functions configuration
      hardware           Configure hardware-specific parameters
      next-hops          Next hop configuration
      rib                Routing table
      route              Route commands
      route-map          Route-map source configuration
      router-id          Configure a general router ID for all routing processes
      segment-routing    Segment Routing configuration
      software           Software configuration
      vrf                Enter VRF sub-mode
    
    switch(config-router-general)#

show bgp evpn

The show bgp evpn command displays information about the BGP-EVPN routes of the switch.

Command Mode

Global Configuration

Command Syntax

show bgp evpn [community | detail | esi esid | extcommunity | host-flap | instance | large-community AS:nn:nn | next-hop | rt | admin:local-assignment | route-type | summary | vni vni_num]

Parameters
  • no parameters     displays all routes of the switch.
  • community     displays routes filtered by the specified community. Options include:
    • GSHUT     well known GSHUT community.
    • aa:nn    AS and network number, separated by colon. The value ranges from 1 to 4294967295.
    • internet     advertises route to the Internet community.
    • local-as     advertises route only to local peers.
    • no-advertise     does not advertise the route to any peer.
    • no-export     advertises route only within the BGP-EVPN AS boundary.
    • comm_num     community number. Values range from 1 to 4294967040.
  • detail     displays detailed information of routes.
  • esi esid     displays routes filtered by the specified Ethernet Segment Identifier (ESI).
  • extcommunity     displays routes that match with BGP or VPN extended community list. Options include:
    • esi-label esid    displays routes filtered by the specified value of ESI label. The value ranges from 0 to 16777215.
    • mac-mobility      displays routes filtered by the specified MAC mobility.
    • rt      displays routes filtered by the specified route target.
    • tunnel-encap vxlan     displays routes filtered by the VXLAN tunnel encapsulation.
    • router-mac H.H.H     displays routes filtered by the specified router MAC address.
  • host-flap     displays routes that contains MAC addresses that are blacklisted due to duplication.
  • instance     displays routes with EVPN instances.
  • large-community AS:nn:nn     displays routes filtered by the specified large community.
  • next-hop     displays routes filtered by next-hop IPv4 or IPv6 addresses of remote VTEP.
  • rd admin:local-assignment     displays routes filtered by the specified Route Distinguisher (RD).
  • route-type     displays routes filtered by NLRI route type.
  • summary     displays summary of routes.
  • vni vni_num     displays routes filtered by the specified VXLAN Network Identifier (VNI). Value ranges from 1 to 4294967294.
Examples
  • This command displays BGP-EVPN routes filtered by the VNI 3011.

    switch(config-router-bgp-af)# show bgp evpn vni 3011
    BGP routing table information for VRF default
    Router identifier 2.0.2.2, local AS number 65002
    Route status codes: s - suppressed, * - valid, > - active, # - not installed, E - ECMP head, e - ECMP
                        S - Stale, c - Contributing to ECMP, b - backup
                        % - Pending BGP convergence
    Origin codes: i - IGP, e - EGP, ? - incomplete
    AS Path Attributes: Or-ID - Originator ID, C-LST - Cluster List, LL Nexthop - Link Local Nexthop
    
             Network                Next Hop            Metric  LocPref Weight  Path
     * >Ec   RD: 3.3.3.1:3011 auto-discovery 0 009a:f13b:53bb:8800:0000
                                    1.1.1.1               -       100     0       65999 65001 i
     *  ec   RD: 3.3.3.1:3011 auto-discovery 0 009a:f13b:53bb:8800:0000
                                    1.1.1.1               -       100     0       65999 65001 i
     * >     RD: 3.3.3.2:3011 auto-discovery 0 009a:f13b:53bb:8800:0000
                                    -                     -       -       0        i
     * >Ec   RD: 3.3.3.1:3011 imet 1.1.1.1
                                    1.1.1.1               -       100     0       65999 65001 i
     *  ec   RD: 3.3.3.1:3011 imet 1.1.1.1
                                    1.1.1.1               -       100     0       65999 65001 i
     * >     RD: 3.3.3.2:3011 imet 1.1.1.2
                                    -                     -       -       0        i
    cvx(config-router-bgp-af)#
  • This command displays the prefixes that are exported to the respective VPN table, along with the route distinguisher.
    switch(config)# show bgp evpn
    BGP routing table information for VRF default
    Router identifier 1.1.1.1, local AS number 65001
    Route status codes: s - suppressed, * - valid, > - active, # - not installed, E - ECMP head, e - ECMP
                        S - Stale, c - Contributing to ECMP, b - backup
                        % - Pending BGP convergence
    Origin codes: i - IGP, e - EGP, ? - incomplete
    AS Path Attributes: Or-ID - Originator ID, C-LST - Cluster List, LL Nexthop - Link Local Nexthop
             Network                Next Hop            Metric  LocPref Weight  Path
     * >     RD: 400:1 ip-prefix 45.0.0.1/32
                                    -                     -       -       0        i
     * >     RD: 400:1 ip-prefix 52.0.0.1/32
                                    -                     -       -       0        i
     * >     RD: 400:1 ip-prefix 120.0.0.0/24
                                    -                     -       -       0        i
     * >     RD: 400:1 ip-prefix 130.0.0.0/24
                                    -                     -       -       0        i
     * >     RD: 400:1 ip-prefix 130.0.1.0/24

show ip bgp vrf

The show ip bgp vrf command displays the type of VPN from the imported route. It shows an indication that the IPv4 route has been leaked and source VRF information is displayed.

Command Mode

Global Configuration

Command Syntax

show ip bgp vrf {vrf_name | all | default}

Parameters
  • vrf_name     name of the VRF.
  • all     displays summary of all VRFs.
  • default     default virtual routing and forwarding instance.

Example

This command displays the leaked and source VRF information.
switch(config)# show ip bgp 13.0.0.0/24 vrf vrf-blue
BGP routing table information for VRF vrf-blue
Router identifier 5.0.0.2, local AS number 65001
BGP routing table entry for 130.110.61.0/24
   4.0.0.3 from 4.0.0.3 (52.0.0.1), imported EVPN route, RD 400:1
      Origin IGP, metric -, localpref 100, weight 0, valid, external,best
      Extended Community: Route-Target-AS:4000:1 TunnelEncap:tunnelTypeVxlan 
EvpnRouterMac:74:83:ef:0b:70:f3
      Leaked from VRF vrf-red

show ip route vrf

The show ip route vrf command displays leaked prefixes with the labelL in the output that indicates that the IPv4 route has been leaked. It also displays information about the source VRF from which these prefixes have been leaked.

Command Mode

Global Configuration

Command Syntax

show ip route vrf {vrf_name | all}

Parameters
  • vrf_name     name of the VRF.
  • all     displays summary of all VRFs.

Example

These commands display the OSPF or OSPFV3 leaked routes as redistribute ospf and redistribute ospfv3 are configured on the source VRF vrf-red.
switch(config)# show ip route vrf vrf-blue
VRF: vrf-blue
Codes: C - connected, S - static, K - kernel,
       O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
       E2 - OSPF external type 2, N1 - OSPF NSSA external type 1,
       N2 - OSPF NSSA external type2, B I - iBGP, B E - eBGP,
       R - RIP, I L1 - IS-IS level 1, I L2 - IS-IS level 2,
       O3 - OSPFv3, A B - BGP Aggregate, A O - OSPF Summary,
       NG - Nexthop Group Static Route, V - VXLAN Control Service,
       DH - DHCP client installed default route, M - Martian,
       DP - Dynamic Policy Route, L - VRF Leaked
Gateway of last resort is not set
C       5.0.0.2/31 is directly connected, Ethernet14
B L  57.0.0.3/32 [200/0] (source VRF vrf-red) via 4.0.0.3, Ethernet11
B L  45.0.0.1/32 [200/0] (source VRF vrf-red) via 4.0.0.3, Ethernet11
B L  52.0.0.1/32 [200/0] (source VRF vrf-red) via 4.0.0.3, Ethernet11
B L  120.0.0.0/24 [200/0] (source VRF vrf-red) via 4.0.0.3, Ethernet11
B L  130.0.0.0/24 [200/0] (source VRF vrf-red) via 4.0.0.3, Ethernet11
B L  130.0.1.0/24 [200/0] (source VRF vrf-red) via 4.0.0.3, Ethernet11
B L  130.0.2.0/24 [200/0] (source VRF vrf-red) via 4.0.0.3, Ethernet11
B L  130.0.3.0/24 [200/0] (source VRF vrf-red) via 4.0.0.3, Ethernet11

show ipv6 bgp vrf

The show ipv6 bgp vrf command displays the type of VPN from the imported route. It shows an indication that the IPv6 route has been leaked and source VRF information is displayed.

Command Mode

Global Configuration

Command Syntax

show ipv6 bgp vrf {vrf_name | all | default}

Parameters
  • vrf_name     name of the VRF.
  • all     displays summary of all VRFs.
  • default     default virtual routing and forwarding instance.

Example

This command displays the leaked and source VRF information.
switch(config)# show ipv6 bgp 2001:10:1:0::102/64 vrf default
BGP routing table information for VRF default
Router identifier 218.218.218.218, local AS number 34
Route status codes: s - suppressed, * - valid, > - active, # - not installed, E 
- ECMP head, e - ECMP
                    S - Stale, c - Contributing to ECMP, b - backup, L - 
labeled-unicast
                    % - Pending BGP convergence
Origin codes: i - IGP, e - EGP, ? - incomplete
AS Path Attributes: Or-ID - Originator ID, C-LST - Cluster List, LL Nexthop - 
Link Local Nexthop

         Network                Next Hop              Metric  LocPref Weight  Path
 * >     2000:0:14:120::/64     2001:db8:1111:9000::  -       100     109     i
 *       2000:0:14:120::/64     2001:db8:156:1010::2  -       100     0       i
 *       2000:0:14:120::/64     2001:db8:152:1010::2  -       100     0       i
 *       2000:0:14:120::/64     2001:db8:203:1010::2  -       100     0       i

show ipv6 route vrf

The show ipv6 route vrf command displays leaked prefixes with the labelL in the output that indicates that the IPv6 route has been leaked. It also displays information about the source VRF from which these prefixes have been leaked.

Command Mode

Global Configuration

Command Syntax

show ipv6 route vrf{vrf_name | all}

Parameters
  • vrf_name     name of the VRF.
  • all     displays summary of all VRFs.

Example

These commands display the OSPF or OSPFV3 leaked routes as redistribute ospf and redistribute ospfv3 are configured on the source VRF vrf-red.
switch(config)# show ipv6 route vrf vrf-blue
VRF: vrf-blue
Displaying 802 of 802 IPv6 routing table entries
Codes: C - connected, S - static, K - kernel, O3 - OSPFv3, B - BGP, R - RIP, A B - BGP Aggregate, 
I L1 - IS-IS level 1, I L2 - IS-IS level 2, DH - DHCP, NG - Nexthop Group Static Route, M - Martian, 
DP - Dynamic Policy Route, L - VRF Leaked
  B L   18::1/128 [200/0] (source VRF vrf-red)
       via 4::3, Ethernet11
  B  L  6::2/127 [200/0] (source VRF vrf-red)
       via fe80::7683:efff:fe0b:963d, Ethernet11
  B  L  45::1/128 [200/0] (source VRF vrf-red)
       via fe80::7683:efff:fe0b:963d, Ethernet11
  B  L  130::/64 [200/0] (source VRF vrf-red)
       via fe80::7683:efff:fe0b:963d, Ethernet11
  B  L  130:0:0:1::/64 [200/0] (source VRF vrf-red)
       via fe80::7683:efff:fe0b:963d, Ethernet11
  B  L  130:0:0:2::/64 [200/0] (source VRF vrf-red)
       via fe80::7683:efff:fe0b:963d, Ethernet11
  B  L  130:0:0:3::/64 [200/0] (source VRF vrf-red)

show l2rib input all

Use the show l2rib input all command to display the Layer 2 RIB input tables migration process.

Command Mode

EXEC

Command Syntax

show l2rib input all [ detail | floodset [ vlan | vtep ] | interface [ Ethernet | Port-Channel ] | mac H.H.H | vlan vlan_id | vtep [ A.B.C.D | A:B:C:D:E:F:G:H ]

Parameters
  • detail Displays a more comprehensive output.
  • floodset Displays L2Rib floodset from input source.
    • vlan Filter by VLAN ID.
    • vtep Filter by VTEP.
  • interface Filter by destination interface.
    • Ethernet Ethernet interface.
    • Port-Channel Link Aggregation Group (LAG).
  • mac H.H.H Filter by MAC address.
  • vlan vlan_id Filter by VLAN ID.
  • vtep Filter by VTEP.
    • A.B.C.D IP address of VTEP.
    • A:B:C:D:E:F:G:H IP address of VTEP.

show l2Rib input vxlan-control-service

Use the show l2Rib input vxlan-control-service to display the migration processes for the VXLAN control service.

Command Mode

EXEC

Command Syntax

show l2Rib input vxlan-control-service [detail | floodset [vlan | vtep] interface [ Ethernet | Port-Channel]| mac H.H.H | vlan vlan_id | vtep [A.B.C.D | A:B:C:D:E:F:G:H]]

Parameters
  • detail Displays a more comprehensive output.
  • floodset Displays L2Rib floodset from input source.
    • vlan Filter by VLAN ID.
    • vtep Filter by VTEP.
  • interface Filter by destination interface.
    • Ethernet Ethernet interface.
    • Port-Channel Link Aggregation Group (LAG).
  • mac Filter by MAC address.
    • H.H.H Ethernet address.
  • vlan vlan_id Filter by VLAN ID.
  • vtep Filter by VTEP.
    • A.B.C.D IP address of VTEP.
    • A:B:C:D:E:F:G:H IP address of VTEP.

show l2rib output

Use the show l2rib output command to display the the Layer 2 RIB utput tables migration process.

Command Mode

EXEC

Command Syntax

show l2rib output [detail | floodset [vlan | vtep] | mac H.H.H | vlan vlan_id | vtep [A.B.C.D | A:B:C:D:E:F:G]

Parameters
  • detail Displays a more comprehensive output.
  • floodset Displays L2Rib floodset from input source.
    • vlan Filter by VLAN ID.
    • vtep Filter by VTEP.
  • interface Filter by destination interface.
    • Ethernet Ethernet interface.
    • Port-Channel Link Aggregation Group (LAG).
  • mac H.H.H Filter by MAC address.
  • vlan vlan_id Filter by VLAN ID.
  • vtep Filter by VTEP.
    • A.B.C.D IP address of VTEP.
    • A:B:C:D:E:F:G:H IP address of VTEP.

show service vxlan address-table

The show service vxlan address-table command displays route entries in the MAC forwarding table that are added through the CVX.

Command Mode

CVX Global Configuration

Command Syntax

show service vxlan address-table {advertised | received}[address H.H.H | evpn | hsc | mss | switch [Word | all] | vni vnid | vtep A.B.C.D]

Parameters
  • advertised     displays the advertised route entries in the MAC forwarding table.
  • received     displays the received route entries in the MAC forwarding table.
  • address H.H.H     displays route entries that are filtered by the specified MAC addresses.
  • evpn     displays route entries filtered by BGP-EVPN.
  • hsc     displays route entries filtered by Hardware Switch Controller (HSC).
  • mss     displays route entries filtered by Macro Segmentation Service (MSS).
  • switch     displays route entries that are filtered by the specified switch or all switches. Options include:
    • Word     Hostname, IP address or ID of the switch.
    • all     all switches.
  • vni vnid     displays route entries filtered by the specified VXLAN Network Identifier (VNI). Value ranges from 1 to 4294967294.
  • vtep A.B.C.D     displays route entries filtered by the specified IP address of the remote Virtual Tunnel End Point (VTEP).
Examples
  • This command displays the route entries in MAC forwarding table advertised to BGP-EVPN peers.
    cvx# show service vxlan address-table advertised evpn
    
             Advertised Mac Address Table
    ----------------------------------------------------------
    VNI          Mac Address    VTEP         Moves
    ----------- ----------------- --------------- -----
    1000         02:01:62:01:00:00 10.0.0.1         1
    Total Mac Addresses for this criterion: 1
    
             Advertised Flood Table
    ---------------------------------------------------
    VNI         Mac Address       VTEP(s)
    ---------- ----------------- ------------------------------
    1000        00:00:00:00:00:00  10.0.0.1     10.0.0.2
    Total Mac Addresses for this criterion: 1
    cvx#
  • This command displays the route entries in MAC forwarding table received from BGP-EVPN peers.
    switch# show service vxlan address-table received evpn
    
          Received Mac Address Table
    -------------------------------------------------------------
    Source      VNI      Mac Address        VTEP       Moves
    ----------- -------- ----------------- ----------- -----
    EVPN        1000     02:01:62:02:00:00  10.0.0.3   1
    Total Mac Addresses for this criterion: 1
    
          Received Flood Table
    --------------------------------------------------------------
    Source          VNI      Mac Address    VTEP
    ----------------- ----------- ----------------- --------------
    EVPN            1000     00:00:00:00:00:00 10.0.0.3
    EVPN            1000     00:00:00:00:00:00 10.0.0.4
    Total Mac Addresses for this criterion: 2
    switch#

show vrf leak flapping

The show vrf leak flapping command displays the flapping prefixes of the routes leaked from one VRF to another VRF. Routes that are detected as “flapping” are blocked considering the future leaking policy execution.

Command Mode

EXEC

Command Syntax

show vrf leak flapping

Parameters
  • destination     displays flapping prefixes destined to a VRF.
  • prefix     displays flapping routes for a prefix.
  • source     displays flapping prefixes sourced from a VRF.
  • vrf     displays flapping prefixes associated with a VRF.

Example

This command displays the flapping prefixes of the leaked routes.
switch# show vrf leak flapping

  Age       Source VRF       Destination VRF       Prefix            Created At 
-------- ---------------- --------------------- ----------------- ------------- 
  141       VRF1             VRF2                  10.0.2.0/24    3357281.40992 

show vxlan control-plane

To enable the user to quickly view which control planes and sources are importing reachability information into which VLANs, use the following show command:

Command Mode

EXEC

show vxlan control-plane [ export vlan [ $ | vlan_id]|import vlan [$ | vlan_id]][vlan [$ | vlan_id]

Parameters
  • export Restricts output to VLANs exporting to a control plane.
    • vlan Specifies specific VLANs to display control plane information.
      • $ List end.
      • vlan_id VLAN ID. Range 1-4094.
  • import Restricts output to VLANs importing from a control plane.
    • $ List end.
    • vlan_id VLAN ID. Range 1-4094.
  • vlan Specifies specific VLANs to display control plane information.
    • $ List end.
    • vlan_id VLAN ID. Range 1-4094.

vlan (VLAN-AWARE-Bundle configuration mode)

The vlan add/ remove command configures the VLAN range string in a VLAN-AWARE-BUNDLE. When the add and remove options are not used, the currently configured range is replaced by the new one . The add and remove options update the currently configured range-aware bundles by adding or removing the provided VLAN range from the currently configured range respectively.

Command Mode

VLAN-AWARE-BUNDLE Configuration

Command Syntax

vlan [add | remove] range

Parameters

range  is the range specified.

Example

These commands take an existing vlan-aware-bundle configuration, corporate_100, and modify it with the add and remove options.

(Existing configuration for corporate_100)
vlan-aware-bundle corporate_100
  rd 1.1.1.1:100
  route-target both 100:100
  vlan 1-10

switch(config-vlan-aware-bundle)#vlan add 1000

(Modified configuration for corporate_100)
vlan-aware-bundle corporate_100
  rd 1.1.1.1:100
  route-target both 100:100
  vlan 1-10, 1000
  
switch(config-vlan-aware-bundle)#vlan remove 5

(Updated configuration for corporate_100)
vlan-aware-bundle corporate_100
  rd 1.1.1.1:100
  route-target both 100:100
  vlan 1-4, 6-10, 1000

vni-aware-bundle

The vni-aware-bundle command configures a BGP MAC-VRF containing Layer 2 routes from a group of VXLAN Network Identifiers (VNI).

Command Mode

Router BGP Configuration

Command Syntax

vni-aware-bundle vni_bundle_name

Parameter

vni_bundle_name    VNI bundle name.

Example

This command configures MAC-VRF BGP to support VNI bundle1.

cvx(config)# router bgp 100
cvx(config-router-bgp)# vni-aware-bundle bundle1
cvx(config-macvrf-bundle1)#